会员登录 还没有账号? 立即注册

WordPress网站定制开发专家
成为WPYOU会员, 享受更多专属优惠吧!

成为WPYOU联盟推广代理,获取高比例的推广佣金分成

立即加入

WordPress 4.8 即将发布

WordPress是一种使用PHP语言开发的博客平台,用户可以在支持PHP和MySQL数据库的服务器上架设属于自己的网站,也可以把WordPress当作一个内容管理系统(CMS)来使用。

WordPress开发团队发布了WP 4.8 Beta1测试版。这是WordPress开发团队在2017年发布的第一个主版本的测试版。据悉,WordPress 4.8正式版也计划于6月8号发布

WordPress 4.8 的主要更新

WordPress 4.8 的主要更新内容包括:

  • TinyMCE 编辑器内联元素/链接的改进;
  • 新的媒体小工具(Widget,挂件);
  • 文本小工具(Widget,挂件)增加所见即所得编辑模式;
  • 控制台将添加新的 WordCamp 聚会活动信息。

WordPress 4.8 的开发工作由 WordPress 创始人 Matt 负责。同时,WordPress 团队将会加快新版本的测试流程,加快新版本的发布速度。

WordPress官方负责自定义功能开发的团队想直接集成上传图片功能到小工具里,具体就是:在添加小工具的地方,直接有一个图片上传的功能按钮,然后直接可以从图片里选择图片并使用图片,具体看以下这张Gif图片:

EtNHycj84H

WordPress 4.8 版本发布计划

以下是 WordPress 4.8 的开发日程计划:

  • 2017.5.12,发布 Beta 1 测试版;
  • 2017.5.19(+1周),发布 Beta 2 测试版;
  • 2017.5.25(+6天),发布 RC 发布候选版;
  • 2017.7.1(+1周),如果有必要,发布 RC 2 发布候选版;
  • 2017.7.7(+6天),练习发布 WordPress 4.8;
  • 2017.7.8(+1天),计划发布 WordPress 4.8 正式版。

WordPress 4.8 Beta 1下载地址:点击这里

另外,根据之前来自WordPress官方消息:Matt Mullenweg 宣布即将推出的 WordPress 4.8 将终止对 Internet Explorer 8/9/10 的支持。核心贡献者们在过去的两个月,一直在讨论浏览器支持与新的编辑器的技术要求的关系。

微软早在 2016年1月份就停止了 Internet Explorer 8/9/10 的更新支持,这就意味着这些旧版本的浏览器将无法获得安全等方面的修复,而下一个版本的 TinyMCE 编辑器已被证实不再支持  Internet Explorer 8/9/10。为了长久发展考虑,WordPress官方最终做出了该决定。

这就意味着,开发者们在 WordPress 4.8 及以后的版本中,将不会再针对 Internet Explorer 8/9/10 进行兼容调试了,如果你还在使用这些版本的浏览器,可能在某些功能上无法正常使用(比如下个版本的TinyMCE 编辑器) ,当然,这个一般来说仅对WP后台有比较大的影响,而对于前端浏览器的支持,取决于主题和插件作者,也就是说,你仍旧可以在前端针对旧版本的浏览器去进行兼容开发。

在线留言

您的昵称 *

您的邮箱 *

您的网站

评论内容

在线客服

点击这里给我发消息 定制开发 购买主题 售前咨询 售后服务
返回顶部