会员登录 还没有账号? 立即注册

WordPress网站定制开发专家
成为WPYOU会员, 享受更多专属优惠吧! 登录

WordPress3.2将放弃PHP4和MySQL4平台

WordPress网站程序运行在较低平台下的用户值得注意了:从WordPress 3.2开始,将不再支持PHP 4和MySQL 4主机环境。

WordPress 开发者一直致力于让WordPress可以运行于更多的主机环境中,可以让用户自由地选择虚拟主机。但现在的虚拟主机环境变化了许多,为了更好地运行WordPress,开发团队决定改变策略:从WordPress 3.2开始,将不再支持PHP 4和MySQL 4主机环境。即将于2010年底发布的WordPress 3.1仍将支持PHP 4环境,这也将是最后一个支持PHP 4的版本。

计划于2011年上半年发布的WordPress 3.2需要的PHP最低版本将是5.2。为什么选择PHP 5.2呢?根据调查显示,大部分用户所使用的主机都高于这个版本,而且包括了PHP 5早期版本所没有的重要功能。同时,Drupal和Joomla下一版本所需要的PHP最低版本也是PHP 5.2。

根据调查,目前只 有11%的用户使用的是PHP 4环境。目前的大部分主机都支持PHP 5.2,有些同时支持PHP 4和PHP5的主机,需要你在主机控制系统里激活PHP 5.2即可。因此,相信到 WordPress 3.2 发布之时,使用PHP 4的用户将进一步减少。

WordPress 3.1仍然可以同时在MySQL 4环境下运行。目前仍有6%的用户使用MySQL 4。在WordPress 3.2及以后版本中,所需要的MySQL最低版本MySQL 5.0.15。

因此,如果你所使用的主机不支持PHP 5.2及MySQL 5.0.15,你将无法升级到WordPress 3.2。WordPress内置的更新功能也将阻止你升级。如果你不确定你的主机是否能够支持将来的WordPress 3.2,你可以下载这个Health Check插件测试一下。如果你的主机不支持,那就应该尽早考虑换一个支持WordPress 3.2的新主机。随着运行环境的提升,WordPress也将会给我们带来一些新的功能和新的体验。来自:cnbeta

在线留言

您的昵称 *

您的邮箱 *

您的网站

评论内容

error: 原创网站主题程序,严禁复制盗用!

在线客服

点击这里给我发消息 定制开发 购买主题 售前咨询 售后服务
返回顶部